image_pdfimage_print

Celem laboratorium jest skonfigurowanie połączenia dwóch sieci LAN z wykorzystaniem warstwy 3 modelu ISO/OSI (L3). Rysunek poniżej przedstawia konfigurację bazową routerów. Oba skonfigurowane są identycznie. Twoim zadaniem jest zmiana konfiguracji urządzeń tak, aby zapewnić możliwość dostępu z sieci LAN1 i LAN2 do sieci Internet oraz zapewnić komunikację pomiędzy sieciami LAN1 i LAN2.

 

Twoje urządzenie R1  (po lewej stronie półki w szafie) połączone jest do sieci Internet poprzez port ETH1, który jest skonfigurowany jako klient DHCP, co oznacza, że dostaje adres IP dynamicznie. Sieć lokalna LAN1 bezpośrednio na routerze R1 jest w klasie IP 10.0.101.0 /24 z gateway na adresie 10.0.101.1. Firewall ma skonfigurowaną „maquarade” z podmianą adresu IP na dane opuszczające port ETH1. Urządzenie R2 (po prawej stronie półki w szafie) posiada sieć LAN2 również w tej samej podsieci IP, co LAN1. Oba urządzenia mają aktywny port SFP+, który musisz połączyć przy pomocy krosu światłowodowego dopiero po wykonaniu konfiguracji na obu urządzeniach. Pamiętaj, aby połączyć złącza światłowodu w odpowiedni sposób tj. nadajnik do odbiornika na obu portach. Nadajnik na portach SFP+ jest na prawym złączu. Porty światłowodowe nie są klasy NWay!

 

 

Każdy port komputera jest przyłączony do gniazdka odpowiednio do oznaczenia w systemie. Port 1 odpowiada gniazdu oznaczonemu przez cyfrę 1.

 

Na gniazdku sieciowym zobaczysz odpowiedni opis w szafie krosowniczej, który zawiera oznaczenie „A, B,C, itp.” oraz numer portu w panelu.

Na przykład dla stanowiska 12 będzie to moduł D i porty od 1-6 do użycia odpowiednio do oznaczeń na stanowisku jak na rysunku poniżej, dla stanowiska 13 będzie to panel D porty od 7-12.

 


Rozpocznij od konfigurowania routera R2.

1. Przypnij odpowiednio gniazdo z portu 3 swojego stanowiska do routera R2 do portu ETH2.

2. Po wykonaniu połączenia (krosowania) uruchom aplikację „WinBox” (na pasku narzędziowym na dole) i przejdź do zakładki „Neighbors”. Znajdziesz tam właściwy router. Możesz połączyć się z nim klikając na adres MAC i podając właściwy login i hasło.

 

Zmień konfigurację sieci LAN routera R2, aby dopasować się do danych prezentowanych na obrazku poniżej.

Ustaw LAN w adresacji IP 192.168.2.0/24 i odepnij port SFP+ od bridge1. Adres routera (bridge1) powinien być ustawiony na 192.168.2.1 (pamiętaj o usunięciu poprzedniej wartości tj. adresu bridge1 10.0.101.1). Dla portu SFP+ ustaw adres statyczny w klasie 192.168.20.8/30 (wyjaśnienie pojęcia masek IPv4 tutaj)- jeden dla routera R2 i drugi adres będzie dla routera R1.

Wykorzystaj w tym celu polecenia terminala.

3. Przy pomocy ustawień w opcji menu „Bridge” odłącz port sfp-sfpplus1 od bridge1. W tym celu użyj przycisku „-” po zaznaczeniu właściwego interfejsu.

4. Następnie zmień ustawienie w opcji „IP->Firewall” w zakładce „NAT” ustawienia masquerade na interfejs wychodzący na „FIBER”.

5. Usuń aktualny adres z domyślnej konfiguracji dla interfejsu bridge1

Wykonaj to poprzez przycisk „-” dla aktualnego adresu

6. Przy użyciu terminala w sekcji „/ip address” dodaj właściwe dane.

add address=192.168.2.1/24 interface=bridge1

7. Nadaj adres IP dla interfejsu sfp-sfpplus1 (podobnie jak w pkt 6 dla interfejsu bridge1)

add address=192.168.20.10/30 interface=sfp-sfpplus1

8. W sekcji „/ip route” zmieniamy domyślny gateway

/ip route
add gateway=192.168.20.9

9. Zmień również ustawienia serwera DHCP. W tym celu w pierwszej kolejności popraw definicję puli adresów. Ustaw pulę na przedział odpowiadający klasie 192.168.2.0/24 w zakresie od 100 do 150

10. Zmień definicję sieci (Networks) w serwerze DHCP podając sieć 192.168.2.0/24 i adres gateway na 192.168.2.1 oraz odpowiedni adres serwera DNS np 8.8.8.8

11. W definicji domyślnego routingu zmień adres na gateway 192.168.20.9

 


Następnie musisz zmienić ustawienia na routerze R1.

12. Przepnij przewód łączący Cię z routerem R2  -> do routera R1 do portu ETH2.

13. Odłącz od bridge1 port sfp-sfpplus1

14. ustaw na nim adres IP kolejny z klasy 192.168.20.8/30 – to jest 192.168.20.9

15. Kolejnym krokiem jest ustawienie routingu do klasy 192.168.2.0/24 poprzez dodanie odpowiedniego wpisu w routingu:

/ip route
add dst-address=192.168.2.0/24 gateway=192.168.20.10

16. Po zakończeniu wszystkich konfiguracji możesz przyłączyć przewód światłowodowy (pamiętaj o właściwym przyłączeniu nadajnika i odbiornika jak opisano wcześniej).


Źródło: www.networkacademy.io

17. Sprawdź działanie odpowiednich interfejsów i ich adresację poprzez wykonanie polecenia ping do adresów z konfiguracji tj.: 192.168.20.9, 192.168.20.10 oraz 192.168.2.1


Uruchomienie systemów operacyjnych gościa do testowania skonfigurowanego środowiska

18. Podłącz odpowiednio przewody swojej stacji do routerów R1 i R2. Wykonaj kros gniazda 1 do portu ETH10 routera R1 oraz kros gniazda 2 do portu ETH10 routera R2.

19. Zmień ustawienia karty sieciowej w maszynie wirtualnej tak aby Win1 działała z kartą „Karta-Port1”, a Win2 działała z kartą „Karta-Port2”.

20. Uruchom maszyny wirtualne na swojej lokalnej maszynie dostępne w oprogramowaniu VMware Workstation Pro. Włącz maszyny VM: Win1 i Win2

21. Na konsoli maszyny WIN1 uruchom polecenie CMD, a w nim wykonaj ping do routera tej maszyny tj. 10.0.101.1.

22 Następnie sprawdź łączność do drugiej sieci poprzez ping do adresu 192.168.2.1

23. Ustal adres IP każdej z maszyn Win1 (powinien być to adres z klasy 10.0.101.0/24) i Win2 (powinien być to adres z klasy 192.168.2.0/24)

24.  Wykonaj ping z maszyny Win1 do maszyny Win2 oraz na odwrót.

25. Wykonaj polecenie ping do jakiegoś adresu internetowego np. google.pl. Potem wykonaj to samo z maszyny VM2.

26. Zadanie wykonane – zgłoś do prowadzącego zajęcia !

27. Rozłącz wszystkie przewody i zresetuj urządzenia R1 i R2 do ustawień domyślnych przyciskiem RESET.