image_pdfimage_print

Mikrotik – łączenie segmentów OSPF AREA poprzez vlink

Celem laboratorium jest wykonanie wielowarstwowej sieci OSPF z dostępem do wszystkich wykazanych poniżej na rysunku sieci lokalnych i ustawieniem domyślnego routingu do siei RIP (Internetu). Struktura sieci oparta na trzech strefach OSPF z wykorzystaniem sprzętu rzeczywistego oraz wirtualnego. Taką strukturę często napotkamy w podstawowych sieciach korzystających z dynamicznego routingu – backbone sieci Area0 oraz przypięte 2 sieci podrzędne Area1 i Area2. Ta struktura tłumaczy problem komunikacji pomiędzy odległymi sieciami OSPF oraz konieczność zapewnienia łączy wirtualnych do opisania tej struktury.

 

 


Podłącz się do routera R1

1. Uruchom skrypt (System / Scripts), który usuwa niepotrzebne ustawienia, automatycznie dodaje adres IP do bridge1 i ustawia serwer DHCP dla bridge1 w odpowiedniej adresacji dla routera R1.

/ip address remove [find interface=bridge1]
/interface bridge port remove [find interface=ether3]
/interface bridge port remove [find interface=ether4]
/interface bridge port remove [find interface=ether5]
/interface bridge port remove [find interface=ether6]
/interface bridge port remove [find interface=ether7]
/interface bridge port remove [find interface=ether8]
/interface bridge port remove [find interface=ether9]
/interface bridge port remove [find interface=ether10]
/interface bridge port remove [find interface=sfp-sfpplus1]
/interface bridge port remove [find interface=WiFi5GHz]
/interface bridge port remove [find interface=WiFi2.4GHz]
/ip pool remove [find interface=dhcp]
/ip dhcp-server remove [find interface=bridge1]
/ip dhcp-server network remove numbers=0
/ip dhcp-server network remove numbers=1
/ip address add address=172.16.1.1/24 interface=bridge1
/ip pool add name=dhcp-pool ranges=172.16.1.200-172.16.1.254 comment="Lab Sieci default"
/ip dhcp-server network add address=172.16.1.0/24 gateway=172.16.1.1 dns-server=8.8.8.8 comment="Lab Sieci default"
/ip dhcp-server add address-pool=dhcp-pool interface=bridge1 disabled=no lease-time=1h

2. Dodaj adres (IP / Addresses) 10.10.10.1/30 do sfp-sfpplus1 – będzie to nasze połączenie pomiędzy routerem R1 i R2

3. Zdefiniuj strukturę OSPF (Routing / OSPF) dla AREA 0.0.0.0

 


Podłącz router R2 (port ETHER2) do karta-port2 i otwórz nowe okno WinBOX do tego rutera

4. Wklej skrypt (System / Scripts), który usuwa niepotrzebne ustawienia, automatycznie dodaje adres IP do bridge1 i ustawia serwer DHCP dla bridge1 w odpowiedniej adresacji dla routera R2.

/ip address remove [find interface=bridge1]
/interface bridge port remove [find interface=ether3]
/interface bridge port remove [find interface=ether4]
/interface bridge port remove [find interface=ether5]
/interface bridge port remove [find interface=ether6]
/interface bridge port remove [find interface=ether7]
/interface bridge port remove [find interface=ether8]
/interface bridge port remove [find interface=ether9]
/interface bridge port remove [find interface=ether10]
/interface bridge port remove [find interface=sfp-sfpplus1]
/interface bridge port remove [find interface=WiFi5GHz]
/interface bridge port remove [find interface=WiFi2.4GHz]
/ip pool remove [find interface=dhcp]
/ip dhcp-server remove [find interface=bridge1]
/ip dhcp-server network remove numbers=0
/ip dhcp-server network remove numbers=1
/ip address add address=172.16.2.1/24 interface=bridge1
/ip pool add name=dhcp-pool ranges=172.16.2.200-172.16.2.254 comment="Lab Sieci default"
/ip dhcp-server network add address=172.16.2.0/24 gateway=172.16.2.1 dns-server=8.8.8.8 comment="Lab Sieci default"
/ip dhcp-server add address-pool=dhcp-pool interface=bridge1 disabled=no lease-time=1h

5. Uruchom załadowany skrypt

6. Jesteśmy na routerze R2, więc najpierw dodaj adres (IP / Addresses) 10.10.10.2/30 do sfp-sfpplus1 (to nasze połączenie pomiędzy routerem R1 i R2).

7. Teraz przystąpimy do opisu OSPF. Utwórz instancję OSPF (Routing / OSPF)

8. Utwórz Area 0

9. Ustaw wzorce sieci dostępne na routerze R2 należące do Area 0.0.0.0

10. Wyłącz regułę Drop na OBYDWU mikrotikach R1 i R2 (IP / Firewall)

10a. Połącz światłowodem mikrotik R1 i R2.

10b. Sprawdź czy na R1 i R2 została ustalona struktura OSPF w ramach Area 0.0.0.0 (Routing / OSPF / Neighbors). Jeżeli w zakładce Neighbors nie masz żadnego wpisu, to oznacza że wcześniej popełniłeś błąd, przejrzyj na spokojnie wszystkie wcześniejsze punkty.

Z poziomu routera R2 ta lista wygląda jak poniżej.

11. Router R2 znajduje się również w AREA 0.0.0.1. Należy to uwzględnić w konfiguracji OSPF. W tym celu zdefiniujemy kolejną Area na tym routerze (Routing / OSPF / Areas).

12. W tej przestrzeni jest kolejny interfejs łączący router R2 z routerem R3. Musimy to opisać po kolei. W pierwszej kolejności nadanie adresu IP dla interfejsu Ether10. IP dla niego to 10.20.20.1/30

13. Potem opisanie wzorca w OSPF dla strefy Area1

Mamy dwie sieci ze strefy Area0 i jedną sieć ze strefy Area1

Potrzebujemy kolejne urządzenia Mikrotik.

13a. Połącz kablem sieciowym port Ether10 routera R2 z gniazdem 3 twojego komputera (Karta-Port3), do której podłączona jest maszyna wirtualna Mikrotik – R3.  

14. Wykonaj koniecznie przywrócenie Snapshot dla tej maszyny przed uruchomieniem.

15. Sprawdź przypisanie maszyny wirtualnej do odpowiednich kart sieciowych. Maszyna musi mieć dwa pierwsze interfejsy przypięte do Custom Karta-Port3, a trzeci pozostaw Host-only.

Jeśli jest poprawnie to uruchom maszynę Mikrotik – R3.

Drugiego routera nie uruchamiaj na razie!

Nie logujemy się do maszyny wirtualnej.

16. Otwórz kolejne okno WinBox i wyszukaj router. Znajdziesz go jako inny typ routera – board będzie x86.

17. Po podłączeniu jako admin z hasłem admin zobaczysz informację o systemie licencjonowania. Potwierdź przyciskiem OK.

18. Sprawdź nazwy interfejsów na wirtualnym Mikrotiku R3 (Interfaces). Powinny się nazywać Ether1 i Ether2. Jeśli tak nie jest to odpowiednio zmień nazwy.

19. Utwórz nową sieć bridge1 (Add + / Bridge).

20. Nadaj adres 172.16.3.1/24 dla bridge1

21. Nadaj dla interfejsu Ether1 adres 10.20.20.2/30. Przez ten interfejs podłączysz go z interfejsem Ether10 routera R2.

22. Zgodnie ze schematem sieci drugi interfejs (Ether2) musi mieć adres 10.30.30.1/30. Nadaj go.

23. Powtarzamy czynności OSPF jak dla poprzednich routerów. Ustanawiamy Instance dla tego routera oraz definiujemy Area1 dla tego routera.

24. Teraz opisz sieci na tym routerze w strefie Area1

25. Jeśli wszystko do tego momentu zrobiłeś poprawnie to routing powinien wyglądać jak poniżej na rysunku. Routery R1, R2, R3 powinny widzieć dostępne sieci. W przeciwnym razie, przejrzyj na spokojnie wszystkie wcześniejsze punkty konfiguracji i znajdź swój błąd.

26. Jeśli widzisz wszystkie 3 sieci 172.16.x.x/24 to możesz przystąpić do definicji strefy Area2

27. Następnie dodamy interfejs (sieć tego interfejsu) do Area2 – 10.30.30.0/30

28. System OSPF oczekuje na odpowiednie połączenie kolejnego routera. Przechodzimy do VMware Workstation i przygotowujemy maszynę Mikrotik – R4.

29. Wykonaj otworzenie ze snapshoot jak w pkt 14 dla maszyny Mikrotik – R3

30. Maszyna musi mieć dwa pierwsze interfejsy przypięte do Custom Karta-Port3, a trzeci interfejs zostaw jako Host-only.

31. Włącz ją i wykonaj kolejne podłączenie z aplikacji WinBox.

32. Utwórz bridge1

33. Sprawdź nazwy interfejsów – powinny być Ether1 i Ether2. Jeśli jest inaczej nadaj im odpowiednie nazwy

34. Nadaj odpowiednie adresy IP zgodnie ze schematem sieci.

35. Dodaj odpowiednio Instances i Area

36. Dodaj wzorce sieci dostępnych w tej strefie

Sieć OSPF powinna zostać ustanowiona i połączona

37. Jeżeli wszystko zostało podłączone prawidłowo i skonfigurowane to tablice routingu poszczególnych routerów będą następujące:

We wszystkich tablicach routingu czegoś brakuje. R1 i R2 widzą sieci 172.16.1.0/24, 172.16.2.0/24 i 172.16.3.0/24 ale nie widzą sieci 172.16.4.0/24. Routery R3 i R4 widzą sieci 172.16.2.0/24, 172.16.3.0/24 i 172.16.4.0/24 jednak nie widzą sieci 172.16.1.0/24. Wszystko z powodu tego że nie ma żadnego z routerów który byłby pomiędzy Area 0.0.0.0 i Area 0.0.0.2. Musimy w jakiś sposób przekazać te informacje wykorzystując Area 0.0.0.1

Zrobimy to poprzez link wirtualny (Virtual Link) pomiędzy routerami R2 i R3

38. Na routerze R2 ustaw w Interface Templates link wirtualny jak poniżej

W polach Vlink Transit Area podajemy tą przez którą ta informacja przeleci czyli Area 0.0.0.1, w polu Vlink Neighbor ID podajemy identyfikator routera na drugim końcu tej strefy czyli routera R3.

39. Na routerze R3 robimy to samo, czyli wskażemy router R2 jednak musimy zrobić coś dodatkowego. Przekazywanie informacji dotyczy wyłącznie backbone czyli area 0.0.0.0 Musimy ją dodatkowo utworzyć na routerze R3.

40. Następnie dodać link wirtualny przez strefę Area 0.0.0.1 jak poniżej podając jako Vlink Neighbor ID router R2

41. Po włączeniu Vlink tablice routingu ulegną zmianie i będą następujące:

42. Sprawdź czy jest ustawione maskowanie adresów NAT na routerze R1 w firewall

I cała struktura powinna mieć dostęp do internetu.

43. Sprawdź na każdym routerze (New Terminal), czy masz dostęp do internetu.